Part of [[ https://linear.app/comm/issue/ENG-3975/rename-holder-blobhash-in-function-and-variable-names-where-applicable | ENG-3975 ]].
Now the `holder` isn't accurate, I decided to name this value `blobURI` because it is of format: either `https://keyserver/uploads/...` or `blob-service://blob-hash`.
For media cache, we have two kind of URIs: `blobURI` - a cache key, and `localURI`/`mediaURI` which is a URI to local multimedia file. I needed to rename these accordingly
In short:
- `holder` -> `blobURI`
- `uri` -> `mediaURI`
- Added some more comments
Depends on D8323