[lib] Rename useCreateChatThreadItem to useGetChatThreadItemLoader
Summary:
- Renames the type CreatedChatThreadItem to ChatThreadItemLoader
- Renames the hook useCreateChatThreadItem to useGetChatThreadItemLoader
These renames make sense in light of the parent diffs, where we lifted some stuff into the CreatedChatThreadItem type, which can now be thought of as handling a transition between initialChatThreadItem and getFinalChatThreadItem.
Depends on D14138
Test Plan: I tested this task by playing around with the ChatThreadList on mobile while using a stopwatch to measure how long various operations took. I tested the updated code 3 times against both the most recent Testflight build as well as master. I found that performance was approximately the same as before. I tested scrolling down, selecting threads that were read, selecting threads that were unread, and search.
Reviewers: tomek, angelika
Reviewed By: tomek
Differential Revision: https://phab.comm.dev/D14139