Quick change. This is more concise because uploadRows already had a insert property to mark the array of values inserted into the uploads table, but since uploadRows was also used to create the UploadMultimediaResult[] return value of createUploads the rest of the object had to be remapped in the return statement of createUploads.
This diff adds the uploadResult property to uploadRows when the uploadInfos are first mapped (by copying the same code that was mapping uploadRows in the return statement) so that the return statement is less redundant and can just map each element of uploadRows to uploadResult.
We could probably go back to using isPinned property here. The thing we undid in D8097. This would make the code more readable, but it's up to you