Quick follow up for this comment. Though we no longer use parseKeysFromQRCodeURL, we have parseInstallReferrerFromInviteLinkURL. I decided to
match the convention with inviteLinkUrl and qrCodeLinkUrl, so I've renamed parseInstallReferrerFromInviteLinkURL to parseInstallReferrerFromInviteLinkUrl.
Details
Ran flow and confirmed no errors
Diff Detail
- Repository
- rCOMM Comm
- Branch
- names
- Lint
No Lint Coverage - Unit
No Test Coverage
Event Timeline
actually after doing a quick global search it seems like the pattern is to have url be "URL" (it's not perfect throughout the codebase, but seems like the majority of cases go with all caps) . Could we make inviteLinkUrl => inviteLinkURL and qrCodeLinkUrl => qrCodeLinkURL
Instead of two separate (action === 'edit_role') blocks, could we merge the two?
We could move await dbQuery(query); within both the (action === 'create_role') (line 139) and else if (action === 'edit_role') (line 144) blocks?
Not a huge deal, whatever you prefer