[lib] rename QRAuthContext to SecondaryDeviceQRAuthContext
Summary: In D14105 I introduced context and turned out, that what I added and existing context on the secondary side have the same names, to avoid confusion I am renaming them to SecondaryDeviceQRAuthContext and PrimaryDeviceQRAuthContext.
Test Plan: Flow
Reviewers: bartek, tomek
Reviewed By: bartek
Subscribers: ashoat
Differential Revision: https://phab.comm.dev/D14166