Page MenuHomePhabricator

[keyserver][lib] Move clientResponseInputValidator to lib

Authored by ashoat on Sat, Jun 8, 3:34 PM.
Referenced Files
F2026125: D12361.id41185.diff
Mon, Jun 17, 2:35 PM
Unknown Object (File)
Sat, Jun 15, 6:50 PM
Unknown Object (File)
Sat, Jun 15, 5:35 PM
Unknown Object (File)
Sat, Jun 15, 2:24 PM
Unknown Object (File)
Sat, Jun 15, 11:17 AM
Unknown Object (File)
Fri, Jun 14, 7:27 AM
Unknown Object (File)
Mon, Jun 10, 5:04 AM
Unknown Object (File)
Mon, Jun 10, 5:01 AM



Initially, I thought I needed to move these to lib because I was about to introduce a new endpoint that took ClientResponses as input.

I ended up removing ClientResponses from the input, so this diff isn't really necessary.

That said, I feel like it's probably "good practice" in our codebase to move all validators to lib, so I decided to put this diff up. If reviewers disagree, I'm open to abandoning it.

Note that this also required moving some validators for reports.

Depends on D12360

Test Plan

This is a pure move diff. Careful code inspection and Flow

Diff Detail

rCOMM Comm
Lint Not Applicable
Tests Not Applicable

Event Timeline

ashoat requested review of this revision.Sat, Jun 8, 3:51 PM
tomek added inline comments.
21–26 ↗(On Diff #41138)

In most of the places we don't use shape suffixes for types and validators, so maybe we can remove them. But it's up to you.

This revision is now accepted and ready to land.Mon, Jun 10, 3:47 AM
21–26 ↗(On Diff #41138)

I think the "shape" suffix is here because the type is not used for a response/result/payload, but rather is a shape that gets combined with some type field before being used for a response/result/payload

21–26 ↗(On Diff #41138)

Ok, makes sense!