consolidated some of the client code to minimize the number of calls we make to DynamoDB. also changed the PAKE_USER_ prefix to USER in constants.rs since the table holds more than just PAKE data now.
Details
cargo build, tested that the update expression worked by creating, updating an item in the DDB table
Diff Detail
- Repository
- rCOMM Comm
- Lint
No Lint Coverage - Unit
No Test Coverage
Event Timeline
services/identity/src/database.rs | ||
---|---|---|
90–98 ↗ | (On Diff #14893) | When only one arm of match expression does useful job, we should use if let instead |
We could probably go back to using isPinned property here. The thing we undid in D8097. This would make the code more readable, but it's up to you