- Queries
- All Stories
- Search
- Advanced Search
- Transactions
- Transaction Logs
Advanced Search
Jul 26 2022
remove redundant boolean cast
I think the title of the diff should reference any chat - not only sidebar.
Address Tomek's sugegstions. Moved callback to thread-utils.js
Replace div with button
removed unused styles
rebase
rebase
rebase
rebase
rebase
In D4457#128083, @ashoat wrote:Agree with both of those conclusions!
We also agreed, that as a follow-up task it would be good to refactor the navigation to keep navigation state in more nested structure
We could create a new backlog task for this one.
wrap default value in useCallback
Jul 25 2022
- Optional: Introduce new action types to separate out the logic in reduceNavInfo(...)
I'm not sure if it's necessary for the case here, but it may be good to cover it with a separate task, as it may help in the future to keep the navigation state consistent.
Replaced "!" with "." and address Tomek's suggestion
address Tomek's suggestions
modified regex so it support only non-empty IDs
In D4461#131918, @ashoat wrote:We could maybe make a Backlog task to make this better (either "zoom" the scrollbar to the part of the inbox that has the thread, or move the thread to the top when it's selected)
Would be good to do this before landing
In D4599#131980, @ashoat wrote:Can you modify the test plan to make sure you test on all relevant browsers? We shouldn't be making big layout changes like this without testing every browser
Jul 22 2022
I may have not enough context about the notifications (maybe it would be good to add linear task reference in diff description), so adding @tomek as blocking reviewer, but I have some comments and questions below:
First, it's good to always add related revisions when some changes depend on other diffs.
I see, that the diff uses variables from D4600, but in D4600 also validateAndroidNotificationByteSize is defined - was it just moved, or is it duplicated? Maybe push/utils.js is a better place for these functions?
I'm not sure if validate... is a good name for the function that mutates an object. Maybe something more like validateAndReduceExceededNotificationSize... would better describe what it does?
What happens if notifications after removing messageInfos still exceeds limits? Shouldn't the size be checked again somewhere after reducing notification and such situation be handled somehow? Or is it impossible to happen?
Jul 21 2022
address Tomek's comment
Returning to review after discussion with Tomek about other possible solutions
changed the types to () => mixed & wrap using useCallback
rename thread to chat & address Tomek's comment
changed the types to () => mixed & wrap using useCallback
Accidentally added description from different diff