- Queries
- All Stories
- Search
- Advanced Search
- Transactions
- Transaction Logs
All Stories
Apr 2 2024
rebase
rebase before landing
address comments
land
Will wait on some CI builds and then land
Change solution
Actually looks like the right solution (that got landed to React Native) is this
Go back to awaiting dispatchActionPromise
Get rid of an invariant
Review feedback
In D11481#331389, @marcin wrote:Accepting but I am of strong opinion that it would be better to create two new structs: NonSyncedKeyserverInfo and SyncedKeyserverInfo that would look exactly the same as original KeyserverInfo. In SQLiteQueryExecutor methods we would just create instances of each class and could rely on simple SQL queries without named parameters. The code would be easier to understand and maintain. It would be two small classes doing simple logic instead of one bigger doing complex logic.
Accepting but I am of strong opinion that it would be better to create two new structs: NonSyncedKeyserverInfo and SyncedKeyserverInfo that would look exactly the same as original KeyserverInfo. In SQLiteQueryExecutor methods we would just create instances of each class and could rely on simple SQL queries without named parameters. The code would be easier to understand and maintain. It would be two small classes doing simple logic instead of one bigger doing complex logic.
rebase before landing
remove const
Just for clarity - could you link diff where keyservers is added to the backup blacklist?
Are we sure that we will never want to inspect the content of keyserver_info values stored in keyserver_synced_data in C++? I am basically asking about the risk that we will have to manually parse JSON-strings in C++ in future.
LGTM for me but please stick to the convention to use SQLiteStatementWrapper.